Bienvenido(a) a Palmadores.net martes, agosto 20 2019 @ 08:22 CEST

Palmadores.net Foros

Instalar chamsys en linux


Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
Hola ante todo, a ver, acabo de pasarme a linux, mentira, llevo años pero hasta ahora había funcionado con la chamsys en un ordenador con ubuntu que funciono solo. Mi querido ordenador ha petado y en otros dos que tengo he instalado en uno ubuntu y en el otro debian, pues bien, cuando le doy al autorun de magicq el ordenador ni se inmuta, asi que a ver si alguien me puede decir que tengo que hacer, he leido lo de las librerias pero tampoco se como hacer ni que librerias bajar.
Asi que si hay algún buen samaritano que me pueda explicar para torpes como hacer lo agradecería.
Gracias

Estado: desconectado

DeMeX

Forum User
Moderador
Identificado: 27/11/03
Mensajes: 1557
Localización:Bilbao
Hay dos métodos:

Usando repositorios:

ChamSys ha creado un repositorio para su software en debian. Es experimental, pero es la forma más sencilla de instalar MagicQ y todas las dependencias. por pasos. Funciona en Debian y debería de funcionar en Ubuntu, pero no lo he probado en este último. Si alguien lo prueba en Ubuntu le agradecería que lo cuente aquí si funciona o no.

1. Abre una terminal
2. wget http://repo.magicq.co.uk/magicq.co.uk.gpg -O - | sudo apt-key add -
3 Añade la siguiente línea al archivo / etc / apt / sources.list (Quita los espacios de la ruta, una protección del foro no deja publicar rutas a archivos del sistema)

deb http://repo.magicq.co.uk/magicq/ magicq main

4. sudo apt-get update
5. sudo apt-get install magicq

MagicQ es un paquete meta que instalará magiq-stable magicq-beta

6. Ejecuta MagicQ como root:

sudo /opt/magicq/runmagicq.sh

También puedes añadir ese directorio a la variable de entorno PATH en tu archivo .bashrc.

Instalar las dependencias manualmente:

MagicQ depende de muchas bibliotecas del sistema. Esto es una característica de GNU/Linux heredada de Unix: que en el sistema sólo haya un programa que realice una función pero que la realice eficientemente. Para saber las bibliotecas que te faltan descomprime el archivo y en un terminal en el mismo directorio escribe:

ldd ./magicq | grep not

La salida del terminal te mostrará las bibliotecas que no tienes instaladas y que tienes que instalar con apt-get, synaptic o aptitude.
No te preocupes por las bibliotecas Qt5, vienen incluídas con MagicQ.

Además hay que repetir la operación con el archivo libqxcb.so en la carpeta platforms. Los archivos que he localizado como dependencias son:

libxcb-sync0 libxcb-icccm4 libxcb-image0 libxcb-render-util0 libxcb-keysyms1 libxcb-randr0 libxcb-xfixes0

pero seguro que hay alguno más. Ejecutando sudo apt-get install libxcb* instalará todos los necesarios y algunos más innecesarios. Estos
paquetes son para Ubuntu precise y Debian Wheezy, si utilizamos otras distros o versiones superiores puede que hayan cambiado de nombre.

Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
Ok, ya esta instalado y estable, pero ahora no me detecta el usb, como lo configuro? Gracias

Estado: desconectado

DeMeX

Forum User
Moderador
Identificado: 27/11/03
Mensajes: 1557
Localización:Bilbao
¿Qué USB? ¿MagicDmx, Enttec, wings, ...?

Si escribes dmesg en terminal después de conectar el usb, ¿cuáles son las últimas líneas?


Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
Hola, otra vez, tengo el Magic dmx, he intentado lo de dmseg pero me dice que no encuentra la orden y " is not in the sudoers file. This incident will be reported"

Estado: desconectado

DeMeX

Forum User
Moderador
Identificado: 27/11/03
Mensajes: 1557
Localización:Bilbao
"dmesg", no "dmseg". No hace falta ejecutarlo con sudo.
Con el MagicDmx enchufado también escribe lsusb, a ver qué sale.

¿tienes instalado el paquete libusb?
¿Has ejecutado el script install_magicdmx.sh? este lo debes ejecutar con sudo

Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
vale he puesto lo de dmesg y en las últimas lineas me pone esto:
[ 1549.507231] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 1549.622342] ISO 9660 Extensions: RRIP_1991A
[ 2232.656061] usb 2-1: new full-speed USB device number 2 using ohci_hcd
[ 2232.868138] usb 2-1: New USB device found, idVendor=10c4, idProduct=857e
[ 2232.868145] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2232.868148] usb 2-1: Product: MagicDMX
[ 2232.868151] usb 2-1: Manufacturer: ChamSys
[ 2234.177029] generic-usb 0003:10C4:857E.0001: hiddev0,hidraw0: USB HID v1.01 Device [ChamSys MagicDMX] on usb-0000:00:0c.0-1/input0
[ 2234.177337] usbcore: registered new interface driver usbhid
[ 2234.177342] usbhid: USB HID core driver
[ 2402.929831] QXcbEventReader[9004]: segfault at b48aaa53 ip b48aaa53 sp b4664300 error 4 in locale-archive[b4923000+177000]

Estado: desconectado

DeMeX

Forum User
Moderador
Identificado: 27/11/03
Mensajes: 1557
Localización:Bilbao
¿el mismo error en Ubuntu y Debian?
¿ejecutaste el script de instalación en los dos?

Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
En ubuntu si que no he podido hacer nada

Estado: desconectado

DeMeX

Forum User
Moderador
Identificado: 27/11/03
Mensajes: 1557
Localización:Bilbao
o sea que el problema es con Ubuntu, ¿Qué versión? ¿32 o 64 bits? ¿da algún mensaje de error al ejecutar el script de instalación? ¿Está el archivo 99-chamsys-magicdmx.rules dentro del directorio / etc/udev/rules.d/?

Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
El problema seguramente no este en Ubuntu, ya te digo que el problema soy yo. Tengo 2 ordenadores, 1 Debian 7 y otro con ubuntu 10.04, En Debian, siguiendo tus pasos me quedo atrancado en el segundo, pero instalando tal y como dice Chamsys, mas descargando librerias se abre el programa pero no detecta el magic dmx (el pincho) y en Ubuntu, ni como dices tu, ni como dice chamsys, ni con librerias, vaya, que no arranca ni el programa.
Menudo lorcis estoy hecho.

Estado: desconectado

jordi-di

Forum User
Carga / Descarga
Identificado: 11/11/13
Mensajes: 7
Supongo que en ubuntu tengo problema con las dependencias, y en debian???? a saber con el cristo que he hecho ya...., luego, una vez que me meto en un terminal o tengo exactamente lo que hay que poner con puntos comas o siempre meto la pata, en algo.
Lo que digo, Mesas de luces, foquitos, sonidetes y montar, lo que quieras pero lo de la informática me supera, UN LORCIS lo que decia

Estado: desconectado

DeMeX

Forum User
Moderador
Identificado: 27/11/03
Mensajes: 1557
Localización:Bilbao
pues no sé qué decirte, a mí me va funciona en Ubuntu 12.04 y en Debian 7, aunque uso un ala en vez del MagicDMX.

Todas las horas son CEST. Hora actual 08:22 .

  • Tópico normal
  • Tópico Pegado
  • Tópico bloqueado
  • Mensaje Nuevo
  • Tópico pegado con nuevo mensaje
  • Tópico bloqueado con nuevo mensaje
  •  Ver mensajes anónimos
  •  Los usuarios anónimos pueden enviar
  •  Se permite todo HTML
  •  Contenido censurado